Support Center

HOWTO: Configuring DEXGate to work with 4noks devices

Last Updated: Jan 19, 2015 04:52PM CET
DEXGate supports a wide range of 4Noks devices. In order to be able to use them first you need to create your 4Noks network and assign unique addresses to all your devices. Once you've done that you'll be able to connect the 4Noks USB device to the DEXGate and start sending data to the server.
The default configuration (below) will work if all your devices have addresses between 15 and 20. If you need more addresses or you don't want to use that range you can change it modifiying the lines bridge.first-node-id and bridge.last-node-id of the configuration file available in the bridge configuration section of the DEXGate web management interface.

Once the USB device is connected in the debug section you should be able to spot a line similar to this:
18-04-12 12:46:02 INFO [MBusManager :: main] - <IDs found: X X 17 X X 20>
The devices showing a X are thoses that haven't been found while the devices with their address are those that are successfully comunicating with the USB device.

Default configuration

# Properties about the mbus bridge:
bridge.speed=19200
bridge.device=/dev/4noks
bridge.ip=127.0.0.1
bridge.port=9001
bridge.polling-interval=30
bridge.first-node-id=15
bridge.last-node-id=20
 
# Properties about the gateway
gateway.interface=eth0
 
# Properties about publishing data
publish.local=false
publish.server=true
 
# Properties about the server
server.default-url=is2.dexcell.com
 
# Hardcoded properties, must be empty or they will be used overriding dynamic configuration
hardcoded.gateway-mac=
hardcoded.server-url=
 
# Properties about the queue
queue.path=/var/tmp/4NoksTempQueue.txt

Contact Us

  • Post a Public Question
  • Email Us
  • Tel : +34 931 810 195
    Hours: 9am - 6pm CEST, Mon to Fri
    support@dexmatech.com

    Check Public holidays here

    Support
support@dexma.com
http://assets1.desk.com/
false
dexma
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete